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LINETYPE , LAYER &  BLOCK 

 

OBJECTIVES 

 At the end of the unit you will be able to : 

 State the method to load and setting the linetype. 

 Explain the benefit of Layer for AutoCAD drawing. 

 Use the dialog box to control the drawing layer. 

 Create a drawing after setting the layer. 

 Use the Block command to transform a group of objects into one object 

that is stored in the current drawing’s block definition table; 

 Use the Insert and Minsert commands to bring Blocks into drawings; 

 Convert Blocks to individual objects with Explode 

 Use Wblock to prepare .DWG files for insertion into other 

drawings; 

 Redefine and globally change previously inserted Blocks; 

 

8.0 Introduction. 

The default linetype in AutoCAD is continuous. Everything you draw is shown with a continuous linetype. The 

linetype can be change by changing a setting at the Layer and Linetype Properties. The step to using a linetype 

are, firstly, the linetype must be loaded from a library and secondly it must be set to ‘current’ status. Once a 

linetype is loaded into AutoCAD you are ready to use it by making it current. That can be done in one of the 

following ways: 

• Assign it to a layer - this is called the Bylayer method 

• Assign it to a block - this is called the Byblock method 

• Assign it to an object - to do this you just make the linetype current  

and draw. 

 

8.1 Load and setting type of line 

Methods for invoking the Linetype include: 

 

 Toolbar  :  

 Pull-down menu : Format > Linetype 

 Command  : Linetype 
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   Figure 8.1 : Layer & Linetype Properties dialog box ( Linetype) 

 

To load a linetypes, just PICK the Load button to view and select from the list of available in the Load or 

Reload Linetype dialog box. 

 

 
 

   Figure 8.2 : Load or Reload Linetype dialog box 

 

Linetype- ByLayer 

 You can associate a linetype with a layer so that the linetype automatically becomes current when the 

layer is current. To do this, follow these steps: 

 

1. Open the Layer and Linetype Properties dialog box by clicking on the icon  or Format > Layer. 
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   figure 8.3 : Layer & Linetype dialog box ( Layer ) 

 

2. In the Layer & Linetype dialog box, click on Continuous under Linetype. 

3. The Select Linetype dialog box opens. Select the linetype you want and click on OK. If it is not listed, 

click on Load and follow the procedure for loading a linetype. 

 

    
    

  Figure 8.4 : Select Linetype dialog box 

 

Linetypes by Object. 

 

It is possible to draw different objects on the same layer with different linetype. Simply draw the object and 

use the grips to apply the loaded linetypes to them. 

 

1. Pick on the object whose linetype you want to change. It will then display the grips. 

2. In the Object Properties toolbar click on the Linetype control down arrow. 
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    Figure 8.5 : Object Properties Dialog Box 

 

3. Highlight the Linetype you want to use. All the loaded linetype will be displayed here. 

4. Press the Esc twice. This removes the grips from the selected object and applies the selected 

linetype. 

 

 

8.2 Benefit of Layer 

  

Layers are invisible elements in an AutoCAD drawing. They are equivalent to sheet of transparent 

film laid on top of one another. Layers allow you to compose a drawing from a selection of drawing elements. 

For example, a building plan may contain details of air-ducting, electrical wiring, piping, flooring furniture etc, 

Each of these details form individual drawing elements, which can be drawn on individual Layers ( known as 

overlay in manual drafting ). These Layer in turn allow you to produce separate electrical, piping and air-

ducting plans for the building. You achieve this by laying the appropriate Layer over the floor plan of the 

building, and printing the resultant composite drawing. 
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    figure 8.6  : How Layers work 

 

8.3 Layer Command 

The easiest way to gain complete layer control is through the Layer tab of the Layer & Linetype Properties 

dialog box. Methods for invoking the Layer include: 

 

 Toolbar:   

 Pull-down menu: Format > Layer 

  Command: Layer 

 
    

Figure 8.7 : Layer tab of Layer and Linetype Properties 
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This dialog box allows full control for all layers in a drawing. Layer existing in the drawing appear in 

the list at the central area ( only Layer 0 will appear foe new drawing created from standard templates such as 

ACAD.DWT ). New layer can be created by selecting the New button near the upper-right corner of the dialog 

box. 

 

8.4 Layer Control by using Dialog box 

 

 

 

   Figure 8.8 : Layer Control 

  

Current or Set 

To Set a layer as the Current layer is to make it the active drawing layer. Any object created with 

draw commands are created on the Current layer. You can, however, edit objects on any layer, but 

draw only on the current layer. To set the current layer with the Layer tab of the Layer & Linetype 

Properties dialog box, select the desired layer from the list and then select the Current tile. Since only 

one layer can be current, it may be necessary to “deselect” highlight layer names from the list until 

only one is highlighted. Alternately, if you are typing, use the Set option of the layer command to 

make a layer OFF. 

 

 ON, OFF  

            If layer is ON, it is visible. Objects on visible layers can be edited or 

plotted. Layers that are OFF are not visible. Objects on layers that are OFF  

will not plot and cannot be edited (unless the ALL selection option is used,  

such as Erase, All). It is not advisable to turn the current layer OFF. 

 

Freeze, Thaw 

              Freeze and Thaw override ON and OFF. Freeze is a more protected state than OFF. Like 

being OFF, a frozen layer is not visible nor can its object be edited or plotted. Objects on a 

frozen layer cannot be accidentally erased with the All option. Freezing unused layers 

speeds up computing time when working with large and complex drawings. Thawing reverse 

the Freezing state. Layers can be Thawed and also turned OFF. Frozen layers are not visible 

even though the light bulb icon is on. 

 

 Lock, Unlock 

Layers that are Locked are protected from being edited but are still visible and can be plotted. 

Locking a Layer prevents its objects from being changed even though they are visible. 
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Objects on Locked layer cannot be selected with the All selection option. Layers can be 

Locked and OFF. 

 

 Freeze in Current Viewport, Freeze in New Viewports. 

These options are used when paper space viewports exist in the drawing. Using these options, 

you can control what geometry (layers) appears in specific viewports.  

 

 Color and Linetype Properties 

 Layers have properties of Colors and Linetype such that an object that is drawn on,  

or changed to, a specific layer assumes the layer’s linetype and color. Using this  

scheme enhances your ability to see what geometry is related by layer. It is also  

possible, however, to assign specific color and linetype to objects that will override the layer’s color 

and linetype. 

 

 Figure 8.9 : Select Linetype Dialog box             Figure 8.10 : Select Color Dialog Box 
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8.5 BLOCK 

A Block is a group of objects that are combined into object with the Block command. The typical application 

for Blocks is in the use of symbols. Many drawings contain symbols, such as doors and windows for 

architectural drawings, capacitors and resistors for electrical schematics, or pumps and valves for piping and 

instrumentation drawings. In AutoCAD, symbols are created first by constructing the desired geometry with 

objects like Line, Arc, and Circle, then transforming the set of objects comprising the symbol into a Block. A 

description of the objects comprising the Block is then stored in the drawing’s “block definition table.” The 

Blocks can then each be Inserted into a drawing many times and treated as a single object. Text can be attached 

to Blocks (called Attributes) and the text can be modified for each Block when inserted. 

Figure 8.11 compares a shape composed of a set of objects and the same shape after it has been made into a 

Block and Inserted back into the drawing. Notice that the original set of objects is selected (highlighted) 

individually for editing, whereas, the Block is only one object. 

 

 

 

Figure 8.11 

Since an inserted Block is one object, it uses less file space than a set of objects that is copied with Copy. The 

Copy command creates a duplicate set of objects, so that if the original symbol were created with 10 objects, 3 

copies would yield a total of 40 objects. If instead the original set of 10 were made into a Block and then 

Inserted 3 times, the total objects would be 13 (the original 10 + 3). 

Upon Inserting a Block, its scale can be changed and rotational orientation specified without having to use the 

Scale or Rotate commands (Fig. 8.12). If a design change is desired in the Blocks that have already been 

Inserted, the original Block can be redefined and the previously inserted Blocks are automatically updated. 

Blocks can be made to have explicit Linetype and Color regardless of the layer they are inserted onto, or they 

can be made to assume the Color and Linetype of the layer onto which they are Inserted. 

 

 

1 object 
10 object 
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     Figure 8.12 

 

   

Blocks created within the current drawing can be copied to disk as complete and separate drawing files (,DWG 

file) by using the Wblock command (Write Block). This action allows you to Insert the Blocks into other 

drawings. Specifically, when you use the Insert command, AutoCAD first searches for the sup plied Block 

name in the current drawing’s block definition table. If the designated Block is not located there, AutoCAD 

searches the directories for a .DWG file with the designated name. 

 

Commands related to using Blocks are: 

Bmake - Invokes a dialog box for creating Blocks  

Block - Creates a Block from individual objects 

Insert - Inserts a Block into a drawing 

Ddinsert- Invokes a dialog box for inserting a Block 

Minsert- Permits a multiple insert in a rectangular pattern 

Explode - Breaks a Block into its original set of multiple objects 

Wblock - Writes an existing Block or a set of objects to a file on disk 

400 
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Base - Allows specification of an insertion base point 

Purge - Deletes uninserted Blocks from the block definition table 

Rename - Allows renaming Blocks 

 

COMMANDS BLOCK and BMAKE 

Methods for invoking the Block or Bmake include: 

 Toolbar :  

 Pull-down menu: Draw > Block…. make 

 Command :    Block 

 

Selecting the icon button, using the pull-down or screen menu, or typing Bmake produces the Block Definition 

dialog box shown in Figure 8.14. This dialog box provides the same functions as using the Block command 

(command line equivalent). 

 

   Figure 8.14 

To make a Block, first create the Lines, Circles, Arcs, or other objects comprising the shapes to be combined 

into the Block. Next, use the Bmake or Block command to transform the objects into one object—a Block. 

If you are using the Block Definition dialog box, enter the desired Block name in the Block name box. Then 

use the Select Objects tile to return to the drawing temporarily to select the objects you wish to comprise the 

Block. After selection of objects, the dialog box reappears. Use the Select Point button in the Base Point 

section of the dialog box if you want to use a point other than the default 0,0 as the “insertion point” when the 

Block is later inserted (usually select a point in the center or corner of the set of objects). When you select OK, 

the objects comprising the Block disappear and the new Block is defined and stored in the drawing’s block 

definition table awaiting future insertions. A check appearing in the Retain Objects checkbox forces AutoCAD 



  EC202 AUTCAD DEC 2010 

   

to retain the original “template” objects (similar to using Oops after the Block command), even though the 

definition of the Block remains in the table. 

The List Block Names tile can be chosen to list all existing Blocks. ( refer to figure 8.15 ) 

 

Figure 8.15. 

If you prefer to type, use Block to produce the command line equivalent of 

Bmake. The command syntax is as follows: 

Command: Block  

Block name (or ?): (name) (Enter a descriptive name for the Block up to 31  characters.)  

Insertion base point: PICK or (coordinates) (Select a point to be used later for insertion.) 

Select objects: PICK 

Select objects: PICK (Continue selecting all desired objects.) 

Select objects: Enter 

The Block then disappears

 

 as it is stored in the current drawing’s “block definition table.” The Oops command 

can be used to restore the original set of “template” objects (they reappear), but the definition of the Block 

remains in the table. Using the ? option of the Block command lists the Blocks stored in the block definition 

table. 

Block Color and Linetype Settings 

The c and linetype of an inserted Block are determined by one of the following settings when the Block is 

created: 
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1.  When a Block is inserted, it is drawn on its original layer with its original Color and 

Linetype (when the objects were created) regardless of the layer or color and linetype 

settings that are current when the Block is inserted (unless conditions 2 or 3 exist). 

2.  If a Block is created on Layer 0 (Layer 0 is current when the original objects comprising the 

Block are created), then the Block assumes the color and linetype of any layer that is current 

when it is inserted (Fig. 8.16).  

    

 

   

 

   

                                           Figure 8.16 

 

3. If  the Block is created with the special BYBLOCK linetype and color setting, the Block is 

inserted with the Color and Linetype settings that are current during insertion whether the 

BYLAYER or explicit object Color and Linetype settings are current. 

 

INSERT and DDINSERT 

Once the Block has been created, it is inserted back into the drawing at the desired location(s) with the Insert 

command. Insert also allows the Blocks to be scaled or rotated upon insertion. The command syntax is given 

here: 

Command: insert 

Block name (or ?): name (Type the name of an existing block or .DWG file to insert.) 

Insertion point: PICK or (coordinates) (Give the desired location of the Block.) 

X scale factor <1>/Corner/XYZ: PICK or (value) (Specifies the size of the Block in the X direction.) 

Y scale factor (default=X): (value) or Enter (Specifies the size in the Y direction.) 

Rotation angle: PICK or (value) (Enter an angle for Block rotation.) 

 

Selecting the “X scale factor” with the cursor specifies both X and Y factors. The rotation angle can be forced 

to 90 degree increments by turning ORTHO (F8) On. 
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Methods for invoking the Insert  include: 

 Toolbar :  

 Pull-down menu : Insert > Block 

 Command :    Insert 

 

The Insert dialog box can be invoked by using the pull-down menu, icon buttons, or tablet menu or by typing 

Ddinsert.  

 

Figure. 8.17.  

Selecting the Block tile causes another box to pop up, listing the Blocks previously defined in the drawing’s 

block definition table.  
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Figure. 8.18 

The desired Block is selected from the  list. Selecting the File tile causes a box to pop up, allowing selection of 

any drawing (.DWG files) from any accessible drive and directory for insertion. The Insert dialog box provides 

explicit value entry of insertion point coordinates, scale, and rotation angle. Explode can also be toggled, 

which would insert the Block as multiple objects (see INSERT with *). 

 

Insert Presets 

Sometimes it is desirable to see the Block in the intended scale factor or rotation angle before you choose the 

insertion point. Insert presets allow you to specify a rotation angle or scale factor before you dynamically drag 

the Block to PICK the insertion point. (Normally, you have to select the insertion point before the prompts for 

scale factor and rotation angle appear.) Presets can be used with the Insert command or Insert dialog box. To 

do this, type in one of the following characters at the “Insertion point:” prompt: 

R rotation angle 

S scale factor (uniform) 

X  X scale factor only 

Y Y scale factor only 

Z Z scale factor only 

For example, to insert a Block at a 45 degree angle using the Insert dialog box, the command syntax reads as 

follows: 

Command: ddinsert (select Block name from the list) 

Insertion point: R (specifies Rotation preset) 
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Rotation angle: 45 (rotates the Block to 45 degrees during dynamic insertion) 

Insertion point: X scale factor <1> / Corner / XYZ: Enter or (value) 

Y scale factor (default=X): Enter or (value) 

Command: 

This action allows you to see the Block at the prescribed rotation angle as you dynamically drag it to PICK the 

insertion point. 

MINSERT 

This command allows a multiple insert in a rectangular pattern (Fig. 8.19). Minsert is actually a combination of 

the Insert and the Array Rectangular commands. The Blocks inserted with Minsert are associated ( the group is 

treated as one object ) and cannot be edited independently ( unless Explode ). Examining the command syntax 

yield the similarly to a Rectangular Array. 

  Command : Minsert 

  Block name ( or ? ) : name 

  Insertion Point : PICK or ( coordinates )  

X scale factor <1>/corner/XYZ : (value) or PICK 

Y scale factor ( default =X) : (value) or Enter 

Rotation Angle: (value) or PICK 

Number of Row (---) : (value) 

Number of Column (III) : (value) 

Unit cell or distance between rows : (value) or PICK (value specifies Y distance from Block 

corner to Block corner; PICK allows drawing a unit cell rectangle). 

 

Distance between Columns : (value) or PICK (Specifies X distance between Blocks corner). 
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      Figure 8.19 

EXPLODE 

Explode breaks a previously inserted Block back into its original set of objects (figure 8.20), which allows you 

to edit individually objects comprising the shape. Blocks that have been inserted with differing X and Y scale 

factor or Blocks that have been Minserted can be exploded in Release 14. There are no option for this 

command. 

 Methods for invoking the Explode include: 

 Toolbar :  

Pull down menu : Modify > Explode 

 Command : Explode 

 

Inserting with an* (asterisk) symbol accomplishes the same goal as using Insert normally, then Explode. 

 

INSERT with * 

Using the Insert command with the asterisk (*) allows you to insert a Block, not as one object, but as the 

original set of objects comprising the Block. In this way, you can edit individual objects in the Block, 

otherwise impossible if the Block is only one object (Fig. 21-10). The normal Insert command is used; 

however, when the desired Block name is entered, it is prefaced by the asterisk (*) symbol: 

Command: insert 

Block name (or ?): * (name) (Type the * symbol, then the name of an existing block or .DWG file to 

insert.) 

Command: 
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This action accomplishes the same goal as using Insert; then Explode. 

 

WBLOCK 

The Wblock command writes a Block out to disk as a separate and complete drawing (.DWG) file. The Block 

used for writing to disk can exist in the current drawing’s Block definition table or can be created by the 

Wblock command. Remember that the Insert command inserts Blocks (from the current drawing’s block 

definition table) or finds and accepts .DWG files and treats them as Blocks upon insertion. 

If you are using an existing Block, a copy of the Block is essentially transformed by the Wblock command to 

create a complete AutoCAD drawing (.DWG) file. The original block definition remains in the current 

drawing’s block definition table. In this way, Blocks that were originally intended for insertion into the current 

drawing can be inserted into other drawings. 

If you want to transform a set of objects to be used as a Block in other drawings but not in the current one, you 

can use Wblock to transform (a copy of) the objects in the current drawing into a separate .DWG file. This 

action does not create a Block in the current drawing. 

As an alternative, if you want to create symbols specifically to be inserted into other drawings, each symbol 

could be created initially as a separate .DWG file. Figure 21-11 illustrates the relationship among a Block, the 

current drawing, and a WBlock. 

 

    figure 8.21 

To create Wblocks (.DWG files) from existing Blocks follow this command syntax: 
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Command: wblock 

(At this point, the Create File dialog box appears, prompting you to supply a name for the .DWG file 

to be created. Typically, a new descriptive name would be typed in the edit box rather than selecting 

from the existing names.) 

Block name: (name) (Enter the name of the desired existing Block. If the file name given in the 

previous step is the same as the existing Block name, an “=“ symbol can be entered at this prompt.) 

Command: 

A copy of the existing Block is then created in the current or selected directory as a Wblock (.DWG file). 

To create a Wblock (.DWG file) to be used as a Block in other drawings but not in the current drawing follow 

the same steps as before, but when prompted for the “Block name:” press Enter or select blank from the screen 

menu. The next steps are like the Block command prompts: 

 

 Command : wblock 

 (The Create Drawing File dialog box appears, prompting you to supply a name for  

the .DWG file to be created.) 

Block Name : (Enter) or (blank) 

Insertion Base Point : PICK or (coordinates) (Pick a point to be used later for  

insertion) 

Select Object : PICK 

Select Object : Enter (Press Enter to complete selection) 

Command : 

 

Settings current when the original objects comprising the Wblock were created. The three possible settings are 

the same as those for Blocks (see the Block command, Color and Linetype Settings). 

When a Wblock is Inserted, its parent (original) layer is also inserted into the current drawing. Freezing either 

the parent layer or the layer that was current during the insertion causes the Wblock to be frozen. 

REDEFINING BLOCKS 

If you want to change the configuration of a Block, even after it has been inserted, it can be accomplished by 

redefining the Block. In doing so, all of the previous Block insertions are automatically and globally updated. 
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  AutoCAD stores two fundamental pieces of information for each Block insertion—the 

insertion point and the Block name. The actual block definition is stored in the block definition table. 

Redefining the Block involves changing that definition. 

To redefine a Block, use the Block command. First, draw the new geometry or change the original “template” 

set of objects. (The change cannot be made using an inserted Block unless it is Exploded because a Block 

cannot reference itself.) Next, use the Block command and select the new or changed geometry. The old Block 

is redefined with the new geometry as long as the original Block name is used. 

Command: block 

Block name (or ?): name (Enter the original Block name.) 

Block (name) already exists. 

Redefine it? <N>: Yes (Answering Y or yes causes the redefinition.) 

Insertion base point: PICK or (coordinates) (Select a point to be used later for insertion.) 

Select objects: PICK 

Select objects: PICK (Continue selecting all desired objects.) 

Select objects: Enter 

Command: 

The Block is redefined and all insertions of the original Block display the new geometry. 

The Block command can also be used to redefine Wblocks that have been inserted. In this case, enter the 

Wblock name (.DWG filename) at the “Block name:” prompt to redefine (actually replace) a previously 

inserted Wblock. 
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